[ create a new paste ] login | about

Link: http://codepad.org/cU1Uj9aq    [ raw code | fork ]

Plain Text, pasted on Mar 12:
$ md5sum *
216d9b3e1b143cb1cfd9dbaea1580edb  PKGBUILD

$ makepkg
==> Making package: ruby1.8-rake 0.8.7-3 (Mon Mar 12 13:53:54 EDT 2012)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
  -> Downloading rake-0.8.7.gem...
--2012-03-12 13:53:55--  http://gems.rubyforge.org/gems/rake-0.8.7.gem
Resolving gems.rubyforge.org... 72.4.120.124
Connecting to gems.rubyforge.org|72.4.120.124|:80... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://production.cf.rubygems.org/gems/rake-0.8.7.gem [following]
--2012-03-12 13:53:55--  http://production.cf.rubygems.org/gems/rake-0.8.7.gem
Resolving production.cf.rubygems.org... 205.251.253.180, 205.251.253.197, 205.251.253.183, ...
Connecting to production.cf.rubygems.org|205.251.253.180|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 104960 (102K) []
Saving to: `rake-0.8.7.gem.part'

100%[==============================================================================>] 104,960     --.-K/s   in 0.1s

2012-03-12 13:53:55 (931 KB/s) - `rake-0.8.7.gem.part' saved [104960/104960]

==> Validating source files with md5sums...
    rake-0.8.7.gem ... Passed
==> Extracting Sources...
==> Starting build()...
==> Entering fakeroot environment...
==> Starting package()...
WARNING:  You don't have /home/max/.gem/ruby/1.8/bin in your PATH,
          gem executables will not run.
Successfully installed rake-0.8.7
1 gem installed
Installing ri documentation for rake-0.8.7...
Installing RDoc documentation for rake-0.8.7...
==> Tidying install...
  -> Purging unwanted files...
  -> Compressing man and info pages...
  -> Stripping unneeded symbols from binaries and libraries...
==> Creating package...
  -> Generating .PKGINFO file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: ruby1.8-rake 0.8.7-3 (Mon Mar 12 13:54:50 EDT 2012)

$ find pkg
pkg
pkg/.PKGINFO
pkg/usr
pkg/usr/bin
pkg/usr/bin/rake-1.8

$ file pkg/usr/bin/rake-1.8
pkg/usr/bin/rake-1.8: broken symbolic link to `/opt/ruby1.8/lib/ruby/gems/1.8/bin/rake'


Create a new paste based on this one


Comments: